1. Здраво и добредојдовте на форумот на IT.mk.

    Доколку сеуште не сте дел од најголемата заедница на ИТ професионалци и ентузијасти во Македонија, можете бесплатно да се - процесот нема да ви одземе повеќе од 2-3 минути, а за полесна регистрација овозможивме и регистрирање со Facebook и Steam.
    Сокриј

Route Your Request To Internet

Дискусија во форумот 'VPN и VLAN' започната од I.Cage, 26 Јуни 2018.

  1. I.Cage

    I.Cage
    Intern

    10
    7
    13 Јуни 2018
    Машко
    Најпрво би објаснал зошто и што е целта.
    Неретко користам една бугарска web страна на која dow тоа што ми треба.
    Во градот во кој живеам моментално блокирана е таа web страна, па едиствена опција е VPN во државата во која нема забрана до таја адреса. Проблемот е што морам постојано да се логирам (dоw торенти) одлогирвам (кога ќе завршам со dow) од VPN. Зошто? "крените VPN и направите tracert :)".

    Користам 2-ва рутери MikroTik еден VPN-Сервер (side 1) другиот е VPN-Client (side 2)
    (side 1)
    - VPN по ваш избор. Во примеров е PPTP (што помалце користите PPTP тоа подобро)
    - ppp=Profiles,Secrets

    (side 2)
    - PPTP-Client pr
    0 R name="pptp-out" max-mtu=1450 max-mru=1450 connect-to=VPN ip address user="test" password="test" profile=default-encryption keepalive-timeout=60
    add-default-route=no dial-on-demand=no allow=mschap2
    Важно: Add Default Route=no, Затоа што не сакаме сите пакети да одат преку оваа конекција.


    /ip firewall address-list
    add address=zamunda.net list=zamund
    (Ова ни овозможува, кои се можните адреси користи од посочениот параметар)

    /ip firewall mangle
    add action=mark-routing chain=prerouting dst-address-list=zamunda new-routing-mark=PBR.Zamunda passthrough=no src-address=192.168.1.0/24
    (Ја маркираме дестинацијата, и одредвиме пулот на адреси)


    /ip firewall nat
    add action=masquerade chain=srcnat out-interface=pptp-client src-address=192.168.1.0/24
    (Одредивме која адреса/и ќе оди по одредет out-interface)

    /ip route
    add distance=1 gateway=pptp-out routing-mark=PBR.Zamunda
    (Oдредуваме кој маркиран/и паакети одат преку PBR)

    Најкусо што е направено?
    - Целиот трафик си оди нормално како што треба да оди, пример кога отвараш google,facebook,youtube и тн. од локалната адреса (кај мене е 192.168.1.1) преку локалниот провајдер, и те носи кај што те носи.
    tracert:
    192.168.1.1
    10.10.202.1

    - Јас само го изменав патоказот на Zamunda.net, таа сега оди од локалната адреса преку VPN адресата на серверот која е 10.11.11.1,фактички оди до дестинацијата преку провајдерот на другата страна,види слика.
    tracert:
    192.168.1.1
    10.11.11.1


    Дали има и друго решение? Нормално дека има, ова е едно од нив. Ова може да има и друга примена (Security). Се зависи што вас ви треба.


    - За крај морам да кажам не сум јас никаков измислител ова е претходно сетирано смислено и тестирано од Reza Moghadam

    ;)
     

    Прикачени датотеки:

    • first.PNG
      first.PNG
      Големина:
      28.3 KB
      Прегледи:
      30
    • second.PNG
      second.PNG
      Големина:
      30.6 KB
      Прегледи:
      25
    Последна промена: 26 Јуни 2018
    На Astro, Oktar, HardCorec и уште 2 други им се допаѓа ова.
  2. Psycore

    Psycore
    Gaining Experience

    385
    295
    12 ноември 2013
    Не ми е јасно дали прашуваш нешто или guide е ова?
     
  3. I.Cage

    I.Cage
    Intern

    10
    7
    13 Јуни 2018
    Машко
    guide е.
     
    Последна промена: 26 Јуни 2018
    На Psycore му/ѝ се допаѓа ова.
  4. I.Cage

    I.Cage
    Intern

    10
    7
    13 Јуни 2018
    Машко
    еве уште една слика и мислам дека се е јасно. Zamunda.net преку VPN серверот и завршува каде што треба. Се останато...по нормален тек на настаните :) ;)
     

    Прикачени датотеки:

    • uu.PNG
      uu.PNG
      Големина:
      202.4 KB
      Прегледи:
      45
    На Psycore му/ѝ се допаѓа ова.

Сподели

Вчитување...