• Здраво и добредојдовте на форумот на IT.mk.

    Доколку сеуште не сте дел од најголемата заедница на ИТ професионалци и ентузијасти во Македонија, можете бесплатно да се - процесот нема да ви одземе повеќе од 2-3 минути, а за полесна регистрација овозможивме и регистрирање со Facebook и Steam.

Проблеми со Nvidia на Fedora 9

  • Ја почнал/а темата
  • #1

WhiteDeath

Intern
2 јуни 2008
117
1
Здраво

Пред некое време го инсталирав Fedora 9.Имам nvidia 8600gt нa asus p5k плоча. Kako прво нејkеше да се инсталира во графички мод па морав да го инстарирам во текстуален мод. Нема врска го инсталирав. Коа заврши со инсталацијата се уклучи конзолата, се логирав како root. Пишав startx за да го стартувам х серверот. Се стартуваше без некој проблем и се појави некоја ок графика . Потоа ја инсталирав Livna со:
rpm -ivhU http://rpm.livna.org/livna-release-9.rpm .

Потоа ја инстарирав графицката преку командата:
yum -y install kmod-nvidia

Си ги симана драјверите и новиот келнер. Побара да се рестартира .
Го рестартирав системот. Откако се подигна пак се стартуваше во конзола. Пак startx .

За да проверам како поминала инсталацијата пишав:
glxinfo | grep direct

На што ми го даде следниот одговор

Error: glXCreateContext failed
X Error of failed request: BadWindow (invalid Window parameter)
Major opcode of failed request: 4 (X_DestroyWindow)
Resource id in failed request: 0x0
Serial number of failed request: 24
Current serial number in output stream: 26
Locking assertion failure. Backtrace:
#0 /usr/lib/libxcb-xlib.so.0 [0x11a7767]
#1 /usr/lib/libxcb-xlib.so.0(xcb_xlib_lock+0x2e) [0x11a790e]
#2 /usr/lib/libX11.so.6 [0x3a8109]
#3 /usr/lib/libX11.so.6(XESetCloseDisplay+0x44) [0x389e14]
#4 /usr/lib/nvidia/libGL.so.1 [0x1757c9]
а и на оваа

[email protected] ~]# glxgears
Error: glXCreateContext failed

Во панелот за апликачии во системските алатки си стоеше апликацијата за подесување на графичката 'nvida display settings' се си работеше најнормално.
Дури и ефектите да десктоп нејкеа да се уклучат.

Потоа пробав и со оваа команда и пак истиот резултат.
su -c 'yum -y install kmod-nvidia xorg-x11-drv-nvidia-libs-32bit'
еве кој верзии на кернелот ги имам и на графицката

[[email protected] ~]# rpm -qa | grep kernel
kernel-headers-2.6.25-14.fc9.i386
kernel-2.6.25.10-86.fc9.i686
kerneloops-0.10-11.fc9.i386
kernel-2.6.25.9-76.fc9.i686
[[email protected] ~]# yum remove (kerneloops-0.10-11.fc9.i386)
bash: syntax error near unexpected token `('
[[email protected] ~]# rpm -qa | grep nvidia
xorg-x11-drv-nvidia-173.14.09-1.lvn9.i386
kmod-nvidia-2.6.25.10-86.fc9.i686-173.14.09-4.lvn9.i686
xorg-x11-drv-nvidia-libs-173.14.09-1.lvn9.i386
kmod-nvidia-173.14.09-4.lvn9.i686
kmod-nvidia-2.6.25.9-76.fc9.i686-173.14.09-2.lvn9.i686
Па се дали има чаре или ке мора да бо преинсталирам Linux-ot

Инак автоматски коа ке пишам startx се дига gnome.
Kakо да направам да се подигне kde.
 

JNenad

Intern
20 декември 2007
38
1
Пробај со драјвери од официјалниот nvidia сајт. Кај мене на федора 8 и 7 работи супер
 
  • Ја почнал/а темата
  • #3

WhiteDeath

Intern
2 јуни 2008
117
1
Како ги инстарираше?
Ги инстарираше со:
sh NVIDIA-Linux-x86-173.14.05-pkg1.run

Или како?
 
  • Ја почнал/а темата
  • #4

WhiteDeath

Intern
2 јуни 2008
117
1
Го угасив хсерверот и пробав така да ги инсталирам, но ми кажа дека требало да се инсталиора соодветна верзија на келнерот и дека требало да се симне и пробав да ја симнам ни не ми успеа. Ми кажа дека немале соодветна врерзија?! и пак ништо...
 

JNenad

Intern
20 декември 2007
38
1
Инсталерот автоматски ке избилда верзија за твојот кернел, потребно е да имаш kernel-headers и ц компјалер
 

Aleks

Gaining Experience
18 мај 2007
5,748
288
Симни си kernel-dev и пробај пак да ги инсталираш драјверите со изгаснат Х сервер. Притоа мора да ги имаш компајлерите инсталирано (C,C++ etc..)за да може да се искомпајлира модулот за графичката.

PS: kernel-devel мора да е иста верзија со кернелот кој го имаш инсталирано. Ако е различна нема да се компајлира. Пробај побарај kernel-devel на http://rpm.pbone.net/ или пробај инсталирај ги со yum , yum install kernel-devel и потоа продолжи со текстуална инсталација. Можеби ќе ти даде грешка дека пак не го нашол source-от па види дали е инсталиран во /usr/src/
 
  • Ја почнал/а темата
  • #8

WhiteDeath

Intern
2 јуни 2008
117
1
Конечно го средив драјверот. Откако ги пробав сите можни начини ми пукна филмот и го реинсталирав Linux-oт. Потоа пишав:
yum -y install kmod-nvidia

Така си се инстарираше новата верзија на келнерот и на драјверите. Откако го рестартирав си работае перфектно. :LOL:

Само уште еdeн проблем има се уште кога ке го уклучам компјутерот ми се подига shell-от. Како да наместам автоматски да ми се подига х серверот (графичката околина) а и да можам да го подигнам и KDE.
 

JNenad

Intern
20 декември 2007
38
1
во /etc/inittab, id:3:initdefault, ке го замениш со id:5:initdefault
 

Нови мислења

Последни Теми

Статистика

Теми
43,529
Мислења
822,690
Членови
28,052
Најнов член
Ttifun
На врв Дно