1. Здраво и добредојдовте на форумот на IT.mk.

    Доколку сеуште не сте дел од најголемата заедница на ИТ професионалци и ентузијасти во Македонија, можете бесплатно да се - процесот нема да ви одземе повеќе од 2-3 минути, а за полесна регистрација овозможивме и регистрирање со Facebook и Steam.
    Сокриј

Проблем со базата при хостирање на сајтот

Дискусија во форумот 'Microsoft SQL Server, MySQL, PostgreSQL, Oracle, S' започната од Ajvio, 6 Јуни 2014.

  1. Ajvio

    Ajvio
    Intern

    10
    1
    21 Мај 2013
    Машко
    Здраво.
    Се работи за аматерско asp.net сајтче. Го направив што го направив на мојот компјутер, се си работеше како што треба, и реков да го поставам на нетов...
    Сите потребни фајлови (вклучувајќи ги и App_Data и App_Code фолдерите) ги ставив во httpdocs фолдерот (зборувам за на сервер страната), и страната си работи ок, единствено кога ќе се посети место каде што ќе треба да се конектира со базата, ми прави проблем. Моја претпоставка е дека најверојатно треба да се конфигурира конекцискиот стринг, но како конкретно треба, не знам. (пишав и на супортот што го најдов во контрол панелот, а и од кај дечките од кај што го земав хостинг просторот (ухост) но немам одговор од ниедна страна)..
    Сајтот за кој што се работи е pamukpale[.]mk , еве кој не го мрзи нека посети некоја категорија од производи менито и ќе види за што станува збор.
    Web.config фајлот ми изгледа вака:
    Код:
    <?xml version="1.0"?>
    <!--
      For more information on how to configure your ASP.NET application, please visit
      http://go.microsoft.com/fwlink/?LinkId=169433
      -->
    <configuration>
      <connectionStrings>
        <add name="dbppConnectionString" connectionString="Data Source=(LocalDB)\v11.0;AttachDbFilename=|DataDirectory|\dbpp.mdf;Integrated Security=True"
          providerName="System.Data.SqlClient" />
      </connectionStrings>
      <system.web>
    <customErrors mode="Off"/>
        <compilation targetFramework="4.5">
          <assemblies>
            <add assembly="System.Data.Linq, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
          </assemblies>
        </compilation>
        <httpRuntime targetFramework="4.5"/>
      </system.web>
    </configuration>
    
    Па ако може да ме насочите/поднаучите како/што треба да направам за да сајтчево проработи?
    Се обидов да прогуглам колку што можам, само се губам, па реков да се обидам и тука да прашам :)
     
  2. Ajvio

    Ajvio
    Intern

    10
    1
    21 Мај 2013
    Машко
    BUMP
    и
    P.S. Серверот има "Parallels Plesk Panel"...
     
  3. null_ptr

    null_ptr
    Gaining Experience

    534
    486
    20 ноември 2013
    Машко
    Сајтот ти враќа грешка:

    [SqlException (0x80131904): A network-related or instance-specific error occurred while establishing a connection to SQL Server.

    Претпоставка дека SQL сервисот на твојот пц и на серверот не е под исто име..
    Отвори за повеќе инфо + види таму со хостинг супорт како е по default

    Провери пак connection string

    (не сум експерт за асп.нет)
     
  4. marv

    marv
    Practice makes perfect

    2,204
    1,496
    5 oктомври 2007
    Машко
    Проблемот ти е во конекцискиот стринг. Убаво кога си работел на localhost арно ам кога се префрлаш на продукциски сервер требаат неколку измени. Од твојот web config фајл одма ми падна во око следново
    Код:
    (localDb)\v11.0
    Ова обично треба да биде
    Код:
    .\SQLXPRESS
    или нешто слично во зависност како серверски е подесен SQL серверот.
    Пробај со овие измени, ако не вклучи дебагирање за апликацијата или во конфиг датотеката и полека полека најди го проблемот.
    Гоогле секогаш може да помогне ;)
     
  5. Ajvio

    Ajvio
    Intern

    10
    1
    21 Мај 2013
    Машко
    Го имав пробано и така конекцискиот стринг, еве баш моментално го впишав како "connectionString="data source=.\SQLEXPRESS;Integrated Security=SSPI;AttachDBFilename=|DataDirectory|dbpp.mdf;User Instance=true" и пак е се исто..
    Го наместив тоа за дебагирање, и да тоа е објаснувањето. во кодот баш кај што прави databind таму ја дава грешката....
    Еве ќе прочачкам уште, па ќе видам...
     
  6. pLaToOn

    pLaToOn
    Gaining Experience

    227
    189
    24 Јануари 2012
    Машко
    Дали пропуштив или немаш напишано каде е дб серверот? И секако, дали си сигурен дека имаш доволно привилегии да атачираш база (ако воопшто името на серверот е точно)?
     
  7. Ajvio

    Ajvio
    Intern

    10
    1
    21 Мај 2013
    Машко
    Она што го добив како одговор од ухост е дека треба да креирам прво база на хостингот во тој Plesk панел. После тоа податоците од локалната база да ги импортирам во таа креирана база.. И после тоа да го сменам конекцискиот стринг..
    Ќе го разгледам утре убаво како да го средам, па ќе видам...
    Фала ви на сите за трудот за да ми помогнете, утре баш ќе пишам апдејт за дали сум успеал или не. (прилично голем неук испаднав со ова :) )
     
  8. marv

    marv
    Practice makes perfect

    2,204
    1,496
    5 oктомври 2007
    Машко
    Охооооо. А ти базата и узерите уште ги немаше креирано :eek:
    Ајде фаќај за туториали. Кога ќе ги искреираш, конекшн стрингот сам ке ти се појави у датабазес. Ако е дефаулт паралелс подесување на серверот, sqlserver е или sqlexpress или mssqlserver2012.… итн
    п.с. многу го мрзам ова плеск-ов :)
     

Сподели

Вчитување...