• Здраво и добредојдовте на форумот на IT.mk.

    Доколку сеуште не сте дел од најголемата заедница на ИТ професионалци и ентузијасти во Македонија, можете бесплатно да се - процесот нема да ви одземе повеќе од 2-3 минути, а за полесна регистрација овозможивме и регистрирање со Facebook и Steam.

PPPoE на Ubuntu

  • Ја почнал/а темата
  • #1

<<ExeCutoR>>

Intern
16 април 2007
132
2
Неможам да се прклучам на интернет, неможам да наместам PPPoE конекција (на МТНет сум закачен, ADSL конекција). Снимав PPPoE client па некеше преку GUI па го куцав и пак некеше :lut2: . Вака без интернет џабе ми е линуксов ништо неможам да правам инаку на dual boot ми е XP/Linux.

Ако на некој му успеало нека пише како да го направам тоа.
 

Commie

Gaining Experience
27 октомври 2007
4,717
218
www.foxmediahouse.com
пробај со pppoeconf или pppoe-setup (за второво не сум сигурен како се пишуваше). Ако евентуално не фаќа тогаш у ќе пишеш sudo pppoeconf. Good luck
 

Aleks

Gaining Experience
18 мај 2007
5,748
288
За да направиш PPPoE конекција мора да си root, значи како што ти кажа COMANDER пиши прво sudo па pppoeconf - sudo pppoeconf и следи ги инструкциите и готово.
 

hmmm

Gaining Experience
30 ноември 2007
1,242
81
hmmm's setup  
Processor & Cooler
i5 3570k @4.2GHz & CM Hyper 212+
Motherboard
AsRock Z77 Pro3
Storage
Samsung 840 EVO 120GB + WD Black 1TB
PSU
Corsair CX600
RAM
2x4GB G.Skill Sniper 1600MHz
Video card
HD4000
Case
Custom
Mouse
Gigabyte GM-M7000
Keyboard
Generic
Audio
Asus Xonar DG
Monitor
Compaq Q2159
OS
Windows 8 64bit
jas samo napisav pppoeconf i toa e se, natamu si ima, ne pisuvav ni sudo ni nisto...:bravo:
 

Laki

Intern
24 февруари 2008
16
0
Aleks, go vnesov "sudo pppoeconf." vo terminalot i dobiv ist odgovor da go vnesam mojot/sudo/password.Ali sistemot ne go prima.Vo sto e sega problemot?
 

Aleks

Gaining Experience
18 мај 2007
5,748
288
Laki, треба да го внесеш истиот password со кој се логираш. Мора да го прифати.
 

Laki

Intern
24 февруари 2008
16
0
Aleks, problemot e sto koga treba da go ufrlam password-ot tasta-
turata voopsto ne funkcionira.Znaci ne e do pogresen password,
tuku problemot e vo toa sto voopsto ne mozam da go ufrlam.Inaku
koga ke upisam "sudo pppoeconf." taa funkcionira.Ne znam zosto
e ova vaka?
 

Laki Luciano

Intern
27 мај 2008
332
3
Не знам дали имаш пробано, но ѕвездичките кои стандардно излегуваат, кога пробуваш да се најавиш со sudo не излегуваат. Пробај (ако веќе не си пробал) искуцај ја лозинката и ентер дали ќе те пушти. Не верувам дека до тастатурата е проблемот. :)
 

DaRkSlidE

Intern
14 мај 2007
152
2
Probaj vnesi go pass-ot i kje vidish deka kje funkcionira, nema zvezdichki vo terminal, zaradi podobra zashtita.. :)
 

Laki

Intern
24 февруари 2008
16
0
Go ufrliv password-ot i ja konfigurirav mrezata uspesno.Izlegov od
terminalot i pokusav da se konektiram,no povtorno bezuspesno.Se
vrativ vo terminalot i go iskucav "sudo pon dsl-provider" i go dobiv
sledniot odgovor:"plugin rp-pppoe. so loaded".Vo sto e sega proble-
mot?Od ova dosega mozam da zaklucam deka Ubuntu e katastrofa kako OS.
 

fuUuUzZzZy

On your way to fame
14 декември 2007
4,842
885
Ohrid
Go ufrliv password-ot i ja konfigurirav mrezata uspesno.Izlegov od
terminalot i pokusav da se konektiram,no povtorno bezuspesno.Se
vrativ vo terminalot i go iskucav "sudo pon dsl-provider" i go dobiv
sledniot odgovor:"plugin rp-pppoe. so loaded".Vo sto e sega proble-
mot?Od ova dosega mozam da zaklucam deka Ubuntu e katastrofa kako OS.
Ах.. ќе си имаш последици од Aleks за ова.. :))
j/k
 

Aleks

Gaining Experience
18 мај 2007
5,748
288
Laki, Хм... ако е катастрофа... зошто го користиш па на крај ?!


Ајде за проблемот, значи, најверојатно нешто ДНС серверите зафркаваат и не се местат автоматски, еве како да ги наместиш:

Оди во терминал, и пиши:

su -

па пиши го твојот пасворд, па кликни ентеРРР

па пиши:

echo nameserver 4.2.2.1 >> /etc/resolv.conf

ЕНТЕР

echo nameserver 4.2.2.2 >> /etc/resolv.conf

ПАК ЕНТЕР

echo nameserver 4.2.2.3 >> /etc/resolv.conf

ЕНТЕР

ktnxbye
 

tanco

Intern
22 април 2008
17
0
ok, chisto za da znaesh sho se sluchilo
"plugin rp-pppoe. so loaded" - znachi deka se e ok, kofiguracijata e ok, pluginot e startan i treba da imash internet,
vo sluchaj da nemash, toa znachi deka ne ti e podesena mrezata, ova ne e zavisno od ubuntuto, ne e do nego, tuku do konfiguracijata so si ja naprail.
kako i da e .. nemoj da gi koristish google dns-ite, znachi namesto 4.2.2.1 -4.2.2.3 kje si gi staish DNS-ite na mtnet
odnosno
sudo gedit /etc/resolv.conf (ako nemash X, toash mesto gedit koristi pico )
i namesto niv stavi si gi
62.162.32.5
62.162.32.6
62.162.32.8
i tolku ..
za da ne se matkash poishe, jas koristam adsl. eve ti konkretno primer za konfiguracijata...

---------------/etc/ppp/peers/dsl-provider

# Minimalistic default options file for DSL/PPPoE connections

noipdefault
defaultroute
replacedefaultroute
hide-password
#lcp-echo-interval 30
#lcp-echo-failure 4
noauth
persist
mtu 1492
#persist
#maxfail 0
#holdoff 20
plugin rp-pppoe.so eth0
user "[email protected]"
usepeerdns

---------------/etc/ppp/peers/dsl-provider
jas koristam Debian ali rpppoe konfiguracijata e ista bez razlika dali koristish ubuntu/arch/bilo koj unix/oid
 

Aleks

Gaining Experience
18 мај 2007
5,748
288
tanco, 4.2.2.2 се root ДНС сервери! Значи се 1000000000000 пати подобри од тие на МтНет или кој било друг! Без нев тотално НИКОЈ друг ДНС сервер не би работил.
 

Laki

Intern
24 февруари 2008
16
0
Aleks,izvini ne znaev deka si tolku osetliv koga e vo prasanje
Ubuntu.Nego da se vratam na mojot problem koj nikako da go resam.Znaci go iskucav su-,go ufrliv password-ot i go dobiv sled-
nio odgovor:"Authentication failure".Ne mi e jasno kako moze da e
password-ot falicen koga so nego dosega uspesno se logiram.Za-
toa otidov na" Network seting'i gi konfigurirav DNS serverite.Poku-
sav da se konektiram preku mozilla,no pak bese bezuspesno.Nez-
nam vo sto e rabotava,zasto vakvo nesto dosega ne mi se sluci-
lo.
 

Aleks

Gaining Experience
18 мај 2007
5,748
288
Laki, де де ... не е до толку ... лол

За проблемот, прво ти треба ПППоЕ конекција а после ДНС да конфигурираш ... не би гледал друг проблем зошто неуспешно се логираш под "su", види нешто МК подршка да немаш уклучено... Ако успешно се логираш, мора и вака да успее...
 

Laki

Intern
24 февруари 2008
16
0
Aleks, da ne e potrebno da se instaliraat Linux driver-i za LAN i
ako treba kako?Jas imam inaku instalirano pokraj Ubuntu, XP i Vista
na prviot HDD,pa zatoa i ne pokusav da gi instaliram naknadno Linux
driver-ite.
 

Aleks

Gaining Experience
18 мај 2007
5,748
288
Laki, не ... скоро 90% ЛАН картицките се подрзани автоматски на Линуксот ..

Linux != Windows
 

gdamjan

On your way to fame
3 април 2008
2,368
657
damjan.softver.org.mk
ја би рекол дека близу 99.9% мрежни карти се подржани во Linux ... Aleks си сретнал некоја за која нема драјвер?

(сум сретнал една која бараше додатен firmware, али го имаше во debian repo и тоа)
 

Aleks

Gaining Experience
18 мај 2007
5,748
288
gdamjan, до сега не, но имам слушнато дека некои модели требаат додатни драјвери да се инсталирааат во кернелот.
 

Fico

Intern
9 март 2008
251
14
Еве и ја скроз нов јузер на убунту, но како и секој имам проблем.
Значи можам да влезам во pppoeconf и ми се појавува она прозорче со eth0 (истото прозорче што е прикажано на линкот малце погоре односно: http://bp1.blogger.com/_IzriXotv1B4/RcQHwcFy8TI/AAAAAAAAAHI/smrrlCiFEaA/s1600-h/pppoeconf.png)

Одам Yes и тоа иде до 100 % еднаш, после мислам набрзинка дека пишува нешто Time Out и после при второто полнење пишува (multi mode). После тоа пак ми го јавува следниот error: Sorry, I scanned 1 interface but the Access Concentrator of your provider did not respond. Another reason for the scan failure may also be another running pppoe process which controls the modem.

Исто така, на самиот panel (оној горе, со конекција) иде Requesting a network address...па после вика дека е Connected за само по неколку секунди повторно да каже Disconnected и пак со requesting-от.

Може ли некој да ми помогне со овој проблем...Малку е безвезе без нет на линуксот а да се бара помош/туториал (мора рестарт, па икспе...)

Исто можеби битна работа за напоменување: Понекогаш (а тоа е доста зачестоно) во самото ХР не можам да се конектирам од прва. Само ми останува на connecting to pppoe...чаре за тоа ми е - disable LAN од Network Connections, вадење адаптер од струја, враќање одма...чекање едно 5 минути, Enable на тоа во Net Conn и дури после се конектирам целосно на нет.

пс: Имам WADSL од Он-нет

Мислам дека дадов доволно детали за проблемов па ако има добра душа:D
 

Aleks

Gaining Experience
18 мај 2007
5,748
288
Fico, проблемот не е до убунтуто туку до антената на ОнНет. Пробај, дур си веќе уклучен на убунтуто да ја рестартираш со вадење на адаптерот и пак ставање по 5-6мин. После неколку минути по рестартирање на антената т.е. неколку минути откако ќе го вретиш адаптерот пиши pppoe-discovery во терминал, и би требало да ти го даде името на првата базна станица на која си конектиран на мрежата на ОнНет. Ако ти покажа Error waiting PADO packets значи повторно пробај да ја рестартираш антената.
 

Fico

Intern
9 март 2008
251
14
Прво фала за брзиот одговор...Но не успеав да се конектирам. Пробувам така цел ден, безуспешно. Error-от е тој, PADO...А дали е некако можно да се среди самата антена ? Да почнам да им досаѓам на тие од ОнНет да дојдат да видат шо и како се дешава?
 

Нови мислења

Последни Теми

Статистика

Теми
43,586
Мислења
824,067
Членови
28,083
Најнов член
Busavata
На врв Дно