1. Здраво и добредојдовте на форумот на IT.mk.

    Доколку сеуште не сте дел од најголемата заедница на ИТ професионалци и ентузијасти во Македонија, можете бесплатно да се - процесот нема да ви одземе повеќе од 2-3 минути, а за полесна регистрација овозможивме и регистрирање со Facebook и Steam.
    Сокриј

Cisco 857

Дискусија во форумот 'LAN // WAN // MAN // PAN // CAN' започната од AlexDGreat, 14 Мај 2009.

  1. AlexDGreat

    AlexDGreat
    Intern

    83
    0
    13 Февруари 2009
    Zdravo treaba da konfiguriram Cisco 857 router, da go vrzam na ADSL, mi treba se razbira DHCP, Firewall, ako se moze i VPN, epa ako ima strucnjaci za Cisco moze da se dogovorime za biznis. Itno mi treba za cena i nadoknada ke se dogovorime. NE SE ZEZAM
    POZDRAV
     
  2. exeit

    exeit
    Intern

    32
    2
    14 Мај 2009
    Имаш доброволец.
     
  3. vlatkorun

    vlatkorun
    Intern

    633
    14
    8 Јуни 2007
    Значи ти треба да подесеш:
    PPPoE конекција на портот кој е кон Интернет(АДСЛ модемо)
    Ти треба рутеро да дава IP адреси на ЛАН-от (DHCP сервер)
    IOS Firewall опција
    Исто така и сетирање на IPSec VPN кон извесна IP адреса кон Интернет.
    Исто така пожелно е дополнителни сетирања на рутеро, највеќе безбедносни.
    Пиши ПП.
     
  4. AlexDGreat

    AlexDGreat
    Intern

    83
    0
    13 Февруари 2009
    dhcp podesov lesno e, ppoe staviv na eden port ama toa so natot me buni,
     
  5. AlexDGreat

    AlexDGreat
    Intern

    83
    0
    13 Февруари 2009
    ne mi se jasni rabotite so ip nat outside-inside bla bla mi dava nekoi greki go nemam teoretskoto znaenje, toa interface dialer, interface ATM0 i taka :)
     
  6. vlatkorun

    vlatkorun
    Intern

    633
    14
    8 Јуни 2007
    Еве ти водич за конфигурирање на твојо модел на рутер.
    Мислам дека овој модел на рутер е наменет за АДСЛ меѓутоа без да го користеш АДСЛ модемо.Значи директно телефонската линија улева у ADSLoPOTS порто.Меѓутоа овој порт користе RJ-45 конектор додека телефонскио кабел користе RJ-11 конектор, така да не ми е малце јасно како да се искофигурира.

    Ајде да пробаме вака:
    Поврзи го АДСЛ модемо на една од ЛАН портите на рутеро, јас ке претпоставам дека е Fastethernet 1.

    conf t
    vlan 100
    exit

    int vlan 1
    desc Virtuelen Interfejs kon LAN-ot
    ip add 192.168.1.1

    int f 1
    switchport mode access vlan 100
    no sh

    int vlan 100
    desc Virtuelen Interfejs kon Internet
    pppoe enable
    pppoe-client dial-pool-number 1
    no sh
    exit

    interface dialer 0
    ip address negotiated
    ip mtu 1492
    ip tcp adjust-mss 1452
    encapsulation ppp
    dialer pool 1
    ppp authentication chap callin
    ppp chap hostname твојот username
    ppp chap password твојот password
    exit

    dialer-list 2 protocol ip permit

    interface dialer 0
    dialer-group 2
    exit

    ip route 0.0.0.0 0.0.0.0 dialer 0

    Сетирање на NAT
    access-list 1 permit 192.168.1.0 0.0.0.255
    ip nat inside source list 1 interface dialer0 overload

    interface dialer 0
    ip nat outside
    exit
    interface vlan 1
    ip nat inside
    exit

    После ова пробај да пингаш од рутеро кон Google, и да за верификација е командата:
    show pppoe session
     
  7. AlexDGreat

    AlexDGreat
    Intern

    83
    0
    13 Февруари 2009
    ovaa e konf zosto ne raboti

    Router#sh run
    Building configuration...

    Current configuration : 2224 bytes
    !
    version 12.4
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Router
    !
    boot-start-marker
    boot system flash c850-advsecurityk9-mz.124-15.T9.bin
    boot-end-marker
    !
    enable secret 5 $1$A5Yf$ri9oLb7F/ADmIvcuwztFF/
    enable password *******
    !
    no aaa new-model
    !
    !
    dot11 syslog
    no ip dhcp use vrf connected
    ip dhcp excluded-address 192.168.0.200
    ip dhcp excluded-address 192.168.0.220
    ip dhcp excluded-address 192.168.0.250
    ip dhcp excluded-address 192.168.0.253
    ip dhcp excluded-address 192.168.0.80
    !
    ip dhcp pool *****
    network 192.168.0.0 255.255.255.0
    default-router 192.168.0.210
    dns-server 93.95.65.6
    !
    !
    ip cef
    ip domain lookup source-interface Dialer0
    ip domain name ******.local
    ip name-server 93.95.65.6
    !
    vpdn enable
    !
    vpdn-template 1
    l2tp tunnel receive-window 128
    !
    !
    !
    username firewall.cx privilege 15 password 0 ciscorocks
    !
    !
    archive
    log config
    hidekeys
    !
    !
    !
    !
    !
    interface ATM0
    no ip address
    shutdown
    no atm ilmi-keepalive
    pvc 8/35
    encapsulation aal5snap
    protocol ppp dialer
    dialer pool-member 1
    !
    dsl operating-mode auto
    !
    interface ATM0.1 point-to-point
    !
    interface FastEthernet0
    !
    interface FastEthernet1
    !
    interface FastEthernet2
    !
    interface FastEthernet3
    !
    interface Vlan1
    ip address 192.168.0.210 255.255.255.0
    ip nat inside
    no ip virtual-reassembly
    pppoe enable group global
    pppoe-client dial-pool-number 1
    !
    interface Dialer0
    description ---ADSL---
    ip address negotiated
    ip nat outside
    no ip virtual-reassembly
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    ppp authentication chap pap callin
    ppp chap hostname ********@t-home.mk
    ppp chap password 0 ******
    ppp pap sent-username *****@t-home.mk password 0 *******
    !
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 Dialer0
    ip route 192.168.0.0 255.255.255.0 Vlan1
    !
    no ip http server
    ip http authentication local
    no ip http secure-server
    ip nat inside source list 100 interface Dialer0 overload
    !
    access-list 1 permit any
    access-list 100 permit ip 192.168.0.0 0.0.0.255 any
    no cdp run
    !
    control-plane
    !
    !
    line con 0
    no modem enable
    line aux 0
    line vty 0 4
    password ********
    login
    !
    scheduler max-task-time 5000
    end

    Router#
     
  8. AlexDGreat

    AlexDGreat
    Intern

    83
    0
    13 Февруари 2009
    рутеров има само 1 vlan

    Router#conf t
    Enter configuration commands, one per line. End with CNTL/Z.
    Router(config)#vlan 100
    Vlan can not be added. Maximum number of 1 vlan(s) in the database.


    Router(config)#vlan ?
    accounting VLAN accounting configuration
    ifdescr VLAN subinterface ifDescr

    а треба да го дава ова според упатството:

    Example:
    Router# config t
    Router(config)#vlan ?
    WORD ISL VLAN IDs 1-4094
    accounting VLAN accounting configuration
    ifdescr VLAN subinterface ifDescr
     
  9. vlatkorun

    vlatkorun
    Intern

    633
    14
    8 Јуни 2007
    А да пробаш овака:
    #vlan database
    (vlan)#vlan 100
    (vlan)#exit

    Мора да ти даде да креираш повеќе VLANs.

    Иначе не ти работе бидејќи Interface ATM или физичкиот интерфејс ADSLoPOTS го поврзуваш на АДСЛ модемо претпоставувам.
    Портата на АДСЛ модемо е Етернет додека портата на рутеро е АДСЛ:имат различни електрични карактеристики, не користат исти жици за праќање/примање на сигнал итн....
     
  10. AlexDGreat

    AlexDGreat
    Intern

    83
    0
    13 Февруари 2009
    ruterot so momentalnava konfiguracija pinga sve zivo, a otvara samo google ...
    cudno mnogu cudno, izgleda deka ne go mirisa voa pppoe mnogu.
    ke probam so ATM ke go brcnam direktno na telefonski kabel bez toa modemot pa jbg ako radi radi ako ne prodavam ruter po povolna cena :plachko2:
    pozdrav i fala na sovetite

    a inace ne mozam da dodeluvam porti na interfejsi po default se na vlan1, neznam kako ide toa so sub-interfejsi probuvav nesto ama ne odi
     
  11. D_P

    D_P
    Intern

    2
    0
    6 ноември 2007
    - Ако од рутерот имаш пинг до google со source IP 192.168.0.210 тогаш интерфејсите се ок исконфигурирани и минимум one-to-one nat постои .

    -За да провериш дали имаш класичен port address translation закачи минимум 2 PC-а позади рутер , пушти (од двата ) пинг или http request и на рутерот куцни sh ip nat translations ( треба да добиеш едно табелче со IP адреси од 192.168.0.0/24 и порти кои ќе се преведат во IP-to што е доделено на dialer0 ) и пејстни ја тука .

    - конфигурацијата мање-више ти е ок (доколку switch-ot што влага во рутер знае што е тоа dot1q VLAN) , за секој случај пробај ја онаа команда со vlan100 што ја напиша vlatkorun , би требало да може да се креира Vlan само незнам баш овој IOS дали дозволува директно во vlan database да се креираат Vlan-и

    - мене лично ми смрди на layer 2 проблем , провери го switchot пак
     
  12. vlatkorun

    vlatkorun
    Intern

    633
    14
    8 Јуни 2007
    Вака, неможеш да го приклучеш телефонскио кабел на ADSLoPOTS порто бидејќи се различни конектори тел.линија е RJ-11, додека ADSLoPOTS е RJ-45.
    Ајде вака искуцај ја show version командата и пастирај го output-от од неа тука да видеме зашо не дава да креираш VLANs.Не сам сретнал Cisco рутер/свич шо има само еден VLAN.
     
  13. vlatkorun

    vlatkorun
    Intern

    633
    14
    8 Јуни 2007
    Јас озбилно не можам да го разберам твојо последен пост. Како мислеш пинга се живо и диво, а отвара само Google?
    Проба ли да креираш Vlan 100 со начино на кој ти кажа јас последен пат?
    Дај повеќе конкретни информации за да ти помогнеме овака не можам баш најдобро:zbunet3:
     
  14. AlexDGreat

    AlexDGreat
    Intern

    83
    0
    13 Февруари 2009
    nemozam da kreiram vlan vo bazata, probav i so drug ios, nemam switch probuvam direktno od pc i pinga se na internet ama......
     
  15. AlexDGreat

    AlexDGreat
    Intern

    83
    0
    13 Февруари 2009
    Router>sh ver
    Router>sh version
    Cisco IOS Software, C850 Software (C850-ADVSECURITYK9-M), Version 12.4(15)T9, RE LEASE SOFTWARE (fc5)
    Technical Support: http://www.cisco.com/techsupport
    Copyright (c) 1986-2009 by Cisco Systems, Inc.
    Compiled Wed 29-Apr-09 08:48 by prod_rel_team

    ROM: System Bootstrap, Version 12.3(8r)YI4, RELEASE SOFTWARE

    Router uptime is 5 minutes
    System returned to ROM by power-on
    System image file is "flash:c850-advsecurityk9-mz.124-15.T9.bin"


    This product contains cryptographic features and is subject to United
    States and local country laws governing import, export, transfer and
    use. Delivery of Cisco cryptographic products does not imply
    third-party authority to import, export, distribute or use encryption.
    Importers, exporters, distributors and users are responsible for
    compliance with U.S. and local country laws. By using this product you
    agree to comply with applicable laws and regulations. If you are unable
    to comply with U.S. and local laws, return this product immediately.

    A summary of U.S. laws governing Cisco cryptographic products may be found at:
    http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

    If you require further assistance please contact us by sending email to
    [email protected].

    Cisco 857 (MPC8272) processor (revision 0x300) with 59392K/6144K bytes of memory.
    Processor board ID FCZ114493XC
    MPC8272 CPU Rev: Part Number 0xC, Mask Number 0x10
    4 FastEthernet interfaces
    1 ATM interface
    128K bytes of non-volatile configuration memory.
    20480K bytes of processor board System flash (Intel Strataflash)

    Configuration register is 0x2102
     
  16. AlexDGreat

    AlexDGreat
    Intern

    83
    0
    13 Февруари 2009
    ok vo slucaj da napravam nov vlan shto potoa port ne mozam da mu dodelam.. ne ja razbiram poentata... a ke zaboravev natot raboti ili vi treba bas tabelata za da vidite dali ima greski..
     
  17. vlatkorun

    vlatkorun
    Intern

    633
    14
    8 Јуни 2007
    Испаѓа дека твојо модел не подржува повеќе VLANs:
    Еве ти линк.

    Чекај малце!Додека си на конзолата на рутеро, можеш ли од тука да пингаш да речеме со extended ping:
    #ping
    !За се ќе притискаш Ентер(default values), само за:
    #Target IP address: www.google.com
    #Extended commands [n]:y
    #Source address or interface: vlan 1

    Доколку имаш reply NAT е функционален.
    Дај пастирај го и #show pppoe session.
     
  18. D_P

    D_P
    Intern

    2
    0
    6 ноември 2007
    Табелата ми треба за да видам inside local - > inside global мапирање .

    Без свич што разбира VLANs би требало да ти помине затоа што е default Vlan 1

    Куцни sh ip route , ако 0.0.0.0 да ти ја даде како directly connected на dialer0 тогаш pppoe-то е во ред.

    Пробај некој од ethernet интерфејсите да го конфигурираш како trunk порта (во овој случај ќе ти треба свич што знае што се tagged пакети , ако најдеш таков свич едната порта што влага во рутерот треба да ти е trunk , а кај што влага PC-to - access порта на влан1 )

    Не е лошо да симнеш ethereal и да пуштиш sniff од проблематичното PC да видиме што му е филмот :)

    edit :
    за секој случај пробај да ја тргнеш ip route 192.168.0.0 255.255.255.0 Vlan1
    и после clear ip route *
    (чисто се сомневам дека ќе смени нешто ама пробај)
     
  19. AlexDGreat

    AlexDGreat
    Intern

    83
    0
    13 Февруари 2009
    imam SMCGS24C-Smart switch ke go bucnam na nego, pppoe raboti samo neznam bas trunk da konfigurirram
     
  20. vlatkorun

    vlatkorun
    Intern

    633
    14
    8 Јуни 2007
    Можам ли јас да ти дадам еден совет.Да идеш да си купеш еден Linksys WRT54GL и да го надградеш со еден од 3d party firmware-рите како шо се Tomato или DD-WRT, и да не се замараш :bravo:
     
  21. AlexDGreat

    AlexDGreat
    Intern

    83
    0
    13 Февруари 2009
    imam zamena za ruterot imam WRT160N ama ne e toa poentata, tolku vreme si poebav na ruterot i na kraj nisto :plachko2:
     
  22. AlexDGreat

    AlexDGreat
    Intern

    83
    0
    13 Февруари 2009
    a na voa cudo ja da mu bapnat telefonska linija direktno i da probam da konfiguriram pppoa namesto pppoe so vikate a :D
     
  23. vlatkorun

    vlatkorun
    Intern

    633
    14
    8 Јуни 2007
    Не можеш, веќе ти кажа у горните постови, имат различни конектори барем од тоа шо можам јас да го видам од слика.Тел. линија користе помал jack (RJ-11) од тој шо го има ADSLoPOTS портата(RJ-45).
     
  24. AlexDGreat

    AlexDGreat
    Intern

    83
    0
    13 Февруари 2009
    epa po se izgleda ne raboti so pppoe kako so treba, trba pppoa da konfiguriram, ke go isfrlam toa d-link modemot posto najverojatno ruterov ima vgraden modem i wan port mu e toj ADSLoPOTS (sto inace go ima) dzabe se tupev so pppoe tolku vreme, e sega na red e ova, fala na pomosta, da se nadevame deka nema da dosagam poveke :D

    Pozdrav
     
Слични теми
  1. mkdwarrior
    Одговори:
    21
    Прегледи:
    3,551
  2. hebocig
    Одговори:
    7
    Прегледи:
    1,487
  3. IntelAmd
    Одговори:
    2
    Прегледи:
    825
  4. MartinK_2
    Одговори:
    3
    Прегледи:
    2,255
Вчитување...

Сподели

Вчитување...